Loading... Please wait...

R4 3DS Affiliate Program

The R4 3DS Newsletter


R4 3DS Cards Now Support 4.5.0 3DS and 1.45 DSi and DSi XL Systems.

Posted on 21st Dec 2012 @ 11:59 AM

As promised last week, our development team has been hard at work ensuring that our cards work on the latest 4.5.0 Nintendo 3DS and Nintendo 3DS XL updates, as well as the Nintendo DSi and Nintendo DSi 1.45 System versions.  After a good 2 weeks of testing, and big fixes, we are happy to report that all of our current lineup of cards are working perfectly on the new 3DS and 3DS XL systems as well as the DSi and DSi XL systems too.  You no longer have to worry about updating your 3DS console as the new firmware provides complete compatibility for all versions of the Nintendo 3DS and 3DS XL systems.  We have tested our firmware on all of our cards, and have loaded them up and have run them on all European, North American (USA/Canada/Mexico) and Japanese 3DS consoles and all of the game consoles have recognized and are working with our R4 3DS, R4i Gold 3DS and R4 3DS RTS Cards.  

Now, we still urge you all to update your R4 cards first, before you install any updates from Nintendo on your system. So make sure you go to our our r4 firmware page, download the latest firmware kernels, and update your cards. Then once that is completed, you can quickly and easily updated your 3DS or DSi consoles as well.

r4 3ds rts